Configuring a Business Objects Resource in Metadata Manager 9.0
Abstract
This article shows how to create and configure a Business Objects resource in Metadata Manager 9.0 to extract metadata from Business Objects 11.5, 12.0, and 12.1.

Supported Versions
- Metadata Manager 9.0

Table of Contents
Overview .............................................................. 2
Configuring Business Objects ............................................. 3
- Install the Metadata Manager Agent. .................................. 3
- Enable the Metadata Manager Agent to Interact with the Desktop. .................................. 3
- Configure Permissions. .............................................. 3
- Export Objects to a Source Repository. ................................. 4
Creating a Business Objects Resource. ..................................... 4
Configuring the Universe Inclusion List. ................................. 6
Troubleshooting .......................................................... 7
Reference ............................................................... 8
- Data Lineage. ....................................................... 8
- Datatypes ............................................................ 8
- Desktop Intelligence Reports. ........................................... 8
- Objects Extracted from Business Objects 5 and 6. ....................... 8
- Objects Extracted from Business Objects 11 and 12. .................... 10

Overview
Business Objects is a business intelligence tool that includes components for performance management, planning, reporting, query and analysis, and enterprise information management.

You can create and configure a Business Objects resource to extract metadata from Business Objects. Metadata Manager extracts metadata objects for Business Objects reports, universes, and repositories.

You can configure a resource for the following Business Objects versions:
- Business Objects 11.5
- Business Objects 12.0
- Business Objects 12.1
- Business Objects 5.x (deprecated)
- Business Objects 6.x (deprecated)
- Business Objects 11.0 (deprecated)
Configuring Business Objects

Before you create a Business Objects resource, you must configure the metadata source. If you do not correctly configure the metadata source, the metadata load can fail or the metadata can be incorrectly loaded in the Metadata Manager warehouse.

To configure Business Objects, complete the following tasks:

- Install the Metadata Manager Agent.
- Enable the Metadata Manager Agent to interact with the desktop.
- Configure permissions.
- Export objects to a repository.

Install the Metadata Manager Agent

The Metadata Manager Agent is a program that Metadata Manager uses to access metadata sources and extract source metadata. By default, the Metadata Manager Agent runs on the nodes where the Metadata Manager Service runs.

The Metadata Manager Agent and a single version of the Business Objects client must be on the same machine. If multiple versions of the Business Objects client are on the same machine as the Metadata Manager Agent, the agent cannot extract the Business Objects metadata.

The Business Objects client must be able to connect to the source repository. If the client is not on the same machine as the Metadata Manager Service, install the Metadata Manager Agent on the same machine as the client.

Enable the Metadata Manager Agent to Interact with the Desktop

If you run the Metadata Manager Agent as a service, you must enable the Metadata Manager Agent to interact with the desktop for the following metadata sources:

- Business Objects
- Microstrategy
- ERwin 7.x Data Modeler (Model Manager)

To enable the Metadata Manager Agent to interact with the desktop:

1. From the Windows Start Menu, click Administrative Tools > Services.
2. Double-click Metadata Manager Agent.
   - The Metadata Manager Agent <Version> Properties dialog box appears.
3. Click the Log On tab.
4. Under Local System Account, click Allow service to interact with desktop.
5. Click OK.

Configure Permissions

Remove permissions from any Business Object universe that you want to export. You cannot extract a write-protected universe. For more information about removing Business Object permissions, see the Business Object documentation.

Make sure that the user who logs in to the Business Object repository belongs to the Universe Designer Users group and has read access to all the Business Objects metadata. If the Business Objects repository contains web intelligence reports in the Favorites or Personal folders, the user should also belong to the Administrators group. You need to create a custom security group giving permission to the user to view Web intelligence reports.
Export Objects to a Source Repository

Export the Business Objects universes, documents, and Crystal Reports to the Business Objects source repository. You can extract documents, universes, and Crystal Reports that have been exported to the source repository. You cannot extract metadata from documents or universes. Export from source repositories to make sure that the metadata in the Metadata Manager warehouse is consistent with the metadata that is distributed to Business Objects users.

To export documents to a source repository:
1. Log in to Business Objects Designer.
2. Open the Business Objects Universe.
3. To export the universe, click **File > Export**.
4. Click **Tools > Desktop Intelligence**.
   The **Business Objects Desktop Intelligence to Publish Business Objects Documents** window appears.
5. Open the Business Objects report.
6. Click **File > Export to Repository**.
   The **Export** dialog box appears.
7. Select the documents to send.
8. Click **OK**.
   Business Objects exports the documents to the source repository.

Creating a Business Objects Resource

Before you create a Business Objects resource, configure the Business Objects source.

To create a Business Objects resource:
1. On the Load tab, click **Actions > New Resource**.
   The **Resource Selection** window appears.
2. Click **Business Intelligence > Business Objects**.
3. Click **Next**.
   The **Properties** page appears.
4. Enter the following information:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name for the resource. The resource appears in the Resources panel with this name. The name must be unique and have from 1 through 256 characters. It cannot include the following characters: /:*?&lt;&gt;</td>
</tr>
<tr>
<td>Description</td>
<td>Description for the resource. Description cannot exceed 4,000 characters.</td>
</tr>
</tbody>
</table>

5. Click **Next**.
   The **Configuration** page appears.
6. In the **Source System Version** list, select the version of Business Objects that you want to connect to.

   Some Business Objects source versions are deprecated and will become obsolete. Use the supported versions to load metadata from Business Objects. You can still create, edit, and load resources from the deprecated versions. However, Informatica cannot help you resolve an issue encountered on a deprecated version.
7. Configure the following resource properties.

The properties that appear depend on the version of Business Objects. The following table describes the properties that you configure:

<table>
<thead>
<tr>
<th>Property</th>
<th>Version</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent URL</td>
<td>All</td>
<td>Host name and port number of the Metadata Manager Agent. You can use the Metadata Manager Agent installed on any machine.</td>
</tr>
<tr>
<td>System</td>
<td>All</td>
<td>Name of the machine where Business Objects is installed and the Business Objects Central Management Server port number on that machine. Enter in the following format: &lt;server_name&gt;:&lt;port_number&gt;</td>
</tr>
<tr>
<td>Authentication mode</td>
<td>All</td>
<td>Select one of the following authentication modes for the user account that logs in to the Business Objects repository:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Enterprise. Log in using the Business Objects Enterprise authentication mode.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- LDAP. Log in using LDAP authentication configured to Business Objects.</td>
</tr>
<tr>
<td>User name</td>
<td>All</td>
<td>User name to log in to the Business Objects repository.</td>
</tr>
<tr>
<td>User password</td>
<td>All</td>
<td>Password of the user account for the Business Objects repository.</td>
</tr>
<tr>
<td>Repository ODBC DSN</td>
<td>5.x, 6.x</td>
<td>Data source to connect to the Business Objects repository. You must use the Business Objects ODBC DSN or the ODBC drivers for the Business Objects database vendor on the machine where the Metadata Manager Agent is located. Note: Do not use a DataDirect ODBC DSN.</td>
</tr>
<tr>
<td>Repository ODBC user name</td>
<td>5.x, 6.x</td>
<td>User name to log in to the database that contains the Business Objects repository. Required if the Business Objects repository database requires a user name and password.</td>
</tr>
<tr>
<td>Repository ODBC user password</td>
<td>5.x, 6.x</td>
<td>Database password for the Business Objects repository. Required if the Business Objects repository database requires a user name and password.</td>
</tr>
<tr>
<td>Repository Subset</td>
<td>All</td>
<td>Business Objects universes that you want to extract. Separate multiple values with a semicolon (;). The syntax depends on the version of Business Objects:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Business Objects 5.x or 6.x. Use &lt;universe domain&gt;/&lt;universe name&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Business Objects 11 or 12. Use &lt;universe folder&gt;/&lt;universe name&gt;.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you configure this property, you cannot configure the list of available universes in the Parameters page.</td>
</tr>
<tr>
<td>Encoding</td>
<td>All</td>
<td>Code page for the Business Objects repository.</td>
</tr>
<tr>
<td>Auto Assign Connections</td>
<td>All</td>
<td>Metadata Manager configures connection assignments to relational database resource types during the resource load. If you disable this option, you must configure connection assignments in the resource properties after you create the resource.</td>
</tr>
</tbody>
</table>

8. Click **Test Connection** to test the connection to the source system and validate the Metadata Manager Agent URL.

If Metadata Manager cannot connect to the source system or validate the agent URL, an error message appears. Correct any error and test the connection again.

9. Click **Next**.

The **Parameters** page appears.
10. Optionally, select **Enable Standalone Document Extraction** to extract standalone documents that are not associated with a universe.

Business Objects documents can be associated with a universe. A standalone document is not associated with a universe.

11. Click **Retrieve/Refresh** to update the Available Universes list with the universes in the Business Objects repository.

If you configured the Repository Subset property on the Configuration page, you cannot specify the universes to extract on the Parameters page.

12. To select the universes that Metadata Manager extracts, choose one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extract metadata from all universes</td>
<td>Extracts metadata from all Business Objects universes in the Business Objects repository that you configure.</td>
</tr>
<tr>
<td>Extract metadata from select universes</td>
<td>Extracts metadata from the Business Objects universes that you select. Use the selected universes list to choose the universes that you want to extract.</td>
</tr>
</tbody>
</table>

13. To add universes to the Selected Universes list, select the universe in the Available Universes list and click **Add**.

14. To add all available universes, click **Add All**.

15. To remove universes from the Selected Universes list, select the universe in the Selected Universes list and click **Remove**.

16. To remove all universes from the Selected Universes list, click **Remove All**.

17. Click **Next**.

The **Schedules** page appears.

18. To add a schedule, select **Attach a Schedule** and select a schedule in the Schedule list.

If you have not created a schedule, you can assign a schedule to a resource after you create the resource.

19. Click **Finish**.

The resource appears in the Resources panel on the Load tab.

### Configuring the Universe Inclusion List

You can configure the Universe Inclusion List parameter for a Business Objects resource. To edit the parameter, select the resource in the Resources panel on the Load tab, click **Edit Resource**, and click the Parameters tab in the Edit Resource window.

**Note:** If you configure the Repository Subset property in the Configuration tab, you cannot configure the Universe Inclusion List. Metadata Manager uses the Repository Subset property to determine the Business Objects universes to extract.

Use the Universe Inclusion list to select the Business Objects universes from which Metadata Manager extracts metadata.

Click **Retrieve/Refresh Universes** to extract a list of available universes from the Business Objects repository. Metadata Manager connects to the Business Object repository to get the available universes. When the list is retrieved, Metadata Manager checks if any universe matches the saved universes in the Included Universes list. Universes that have not been saved are removed from the Included Universes list.

Click **Retrieve/Refresh Universes** to refresh the list of available Universes each time you access the Parameter tab.
Troubleshooting

I loaded a Business Objects resource in Metadata Manager, but encountered the following error in the Metadata Manager Agent log file:

Cannot initialize Business Objects Reporter API

Use one of the following methods to fix the error:

- Verify that you can open the Business Objects client and open the repository.
- Verify that the Windows COM API is installed.
- Verify that you select the correct tool version for the Source system version.
- Verify that no busobj.exe process is running.
- Verify that the latest service pack is installed for Business Objects.

You can keep the Business Objects Designer open without opening any universes. The Metadata Manager Agent stops the Business Objects Designer.

Even though the universe is in the right location, I get the following error in the Metadata Manager Agent log file when I load a Business Objects resource:

[MBI_BODSER_0056] Business Objects Designer could not open the Universe <universe path>\<universe name>.unv

The universe you want to load is password protected or you configured a write reservation password.

To fix the error, complete the following steps:

1. Log in to the Business Objects Designer.
2. Open the Business Objects universe.
3. Click Tools > Options.
4. On the Save tab for File Sharing Options for <universe name>, remove the password for Write Reservation Password.
5. Verify that Remove Protection Password is not selected.
6. Export the universe to a folder.
7. Import the universe to confirm that a password message does not appear.
8. Log in to Metadata Manager.
10. Click the Parameters tab, and then click Retrieve/Refresh Universe.
11. Click OK.
12. Load the resource again.

When I click Retrieve/Refresh Universe for a Business Objects resource, I get the following error:

com.informatica.metadata.services.imas.AcquisitionException: Metadata Manager Agent failed to extract metadata from source

This error can occur due to the following reasons:

- The Metadata Manager Agent URL is incorrect or the Metadata Manager Agent is not running. To test the Metadata Manager Agent URL, go to the following URL on the machine where you installed the Metadata Manager Agent:
  http://<host name>:<port>/MIMBWebServices
- The repository name or repository user name is incorrect. Verify that you enter the fully qualified host name of the machine where the Business Objects server runs. The repository user name is the user name you use to log in to the Business Objects Designer.
The Business Objects Server is in a remote location and is not accessible from the machine where the Metadata Manager Agent runs. To extract universes, the Metadata Manager Agent communicates with the Business Objects server. For example, the Metadata Manager Agent and the Business Objects server may not be in the same network. Verify that the Business Objects server is accessible by the Metadata Manager Agent.

The Business Objects server and Metadata Manager Agent are separated by a firewall. Ask your system administrator to open the port where the Metadata Manager Agent runs in the firewall. By default, the Metadata Manager Agent runs on port 19983.

Reference

After you create and load a Business Objects resource, you can view and run data lineage on the metadata objects that Metadata Manager extracted.

Data Lineage

Data lineage does not display synthetic universe objects for a non-universe data provider, such as metrics, attributes, or schema tables.

Datatypes

Metadata Manager does not extract the actual datatype of a column or dimension object.

The following table lists the actual datatypes and the datatypes that Metadata Manager uses:

<table>
<thead>
<tr>
<th>Datatype Representation</th>
<th>Actual Datatype</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character</td>
<td>char</td>
</tr>
<tr>
<td>Date</td>
<td>datetime</td>
</tr>
<tr>
<td>Long Text</td>
<td>binary</td>
</tr>
<tr>
<td>Number</td>
<td>number</td>
</tr>
</tbody>
</table>

Desktop Intelligence Reports

The Business Objects Desktop Intelligence application shows the reports from the personal folder for the current user. As a result, Metadata Manager extracts Business Objects Desktop Intelligence reports from a personal user folder only, even if the user is an administrator. Metadata Manager extracts reports from the personal folder for the user account that you configure for the resource.

In addition, Metadata Manager does not extract Desktop Intelligence reports from the Favorites folder.

Objects Extracted from Business Objects 5 and 6

The objects that Metadata Manager extracts depend on the version of Business Objects that you extract metadata from.
The following table lists the classes of objects extracted from components in Business Objects 5 and 6:

<table>
<thead>
<tr>
<th>Extracted from Desktop Intelligence Reports</th>
<th>Extracted from a Universe</th>
<th>Extracted from the Repository</th>
</tr>
</thead>
<tbody>
<tr>
<td>DataProvider</td>
<td>Class</td>
<td>Connection</td>
</tr>
<tr>
<td>DataProviderColumn</td>
<td>Column</td>
<td>DataType</td>
</tr>
<tr>
<td>DataProviderDataset</td>
<td>Condition</td>
<td></td>
</tr>
<tr>
<td>DetailVariable</td>
<td>CustomHierarchy</td>
<td></td>
</tr>
<tr>
<td>DimensionVariable</td>
<td>CustomHierarchyLevel</td>
<td></td>
</tr>
<tr>
<td>Document</td>
<td>DefaultHierarchy</td>
<td></td>
</tr>
<tr>
<td>MeasureVariable</td>
<td>DefaultHierarchyLevel</td>
<td></td>
</tr>
<tr>
<td>Query</td>
<td>DetailObject</td>
<td></td>
</tr>
<tr>
<td>QueryCondition</td>
<td>DimensionObject</td>
<td></td>
</tr>
<tr>
<td>QueryObject</td>
<td>Join</td>
<td></td>
</tr>
<tr>
<td>Report</td>
<td>MeasureObject</td>
<td></td>
</tr>
<tr>
<td>ReportCell</td>
<td>Table</td>
<td></td>
</tr>
<tr>
<td>ReportChart</td>
<td>Universe</td>
<td></td>
</tr>
<tr>
<td>ReportCrossTab</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportField</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportFieldConstant</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportFieldDetail</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportFieldDimension</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportFieldFormula</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportFieldMeasure</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportFooter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportHeader</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportSection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReportTable</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The following classes of objects do not exist in BusinessObjects, but are created in the Business Objects model for Metadata Manager purposes:

- BOClassifierExpressions
- BOFeatureExpression
- Object
- TaskDefinition
- TransformationMap

Metadata Manager does not extract the following objects from Business Objects 5 and 6:

- Business Objects Encyclopedia
- Context objects
- Creation dates for attributes
- Crystal Reports
- Crystal Xcelsius
- Dashboards
- Derived Business Objects datatypes
- Document folders and categories for Desktop Intelligence reports
- Document folders that do not contain documents or reports
- Intelligent questions
- OLAP Intelligence reports and connections
- Path attribute for the Report Document object
- Query Object attribute for the Query Condition object
- Query Operator attribute for the Query object
- Report alert
- Repository groups, users, profiles, servers, and server groups
- Scheduling and publishing metadata
- Scorecards
- Strategy maps
- Universe folders
- WebIntelligence documents (not extracted from Business Objects 6)

**Objects Extracted from Business Objects 11 and 12**

The objects that Metadata Manager extracts depend on the version of Business Objects that you extract metadata from.

The following table lists the classes of objects extracted from components in Business Objects 11 and 12:

<table>
<thead>
<tr>
<th>Extracted from Desktop Intelligence and Web Intelligence Reports</th>
<th>Extracted from Crystal Reports</th>
<th>Extracted from a Universe</th>
<th>Extracted from the Repository</th>
</tr>
</thead>
</table>

The following classes of objects do not exist in Business Objects, but are created in the Business Objects model for Metadata Manager purposes:

- BOClassifierExpressions
- BOFeatureExpression
- Object
- TaskDefinition
TransformationMap

Metadata Manager does not extract the following objects from Business Objects 11 and 12:

- Business Objects Encyclopedia
- Categories that do not contain documents or reports
- Context objects
- Creation dates for attributes
- Crystal Reports class types, including Running Total, SQL expression, Group, OLAP grid, OLE, Hyperlink, Map and Alert. Crosstab is extracted, but Crosstab attributes are not extracted.
- Crystal Xcelsius
- Dashboards
- Derived Business Objects datatypes
- Document folders that do not contain documents or reports
- Intelligent questions
- OLAP Intelligence reports and connections
- Path attribute for the Report Document object
- Query Object attribute for the Query Condition object
- Query Operator attribute for the Query object
- Report alert
- Repository groups, users, profiles, servers, and server groups
- Scheduling and publishing metadata
- Scorecards
- Strategy maps

Author

Alison Taylor
Technical Writer

Acknowledgments

The author would like to acknowledge Lewis Gault, Krishna Kumar, and Manjusha Musugu.