Importing a COBOL or PL/I Copybook into a PowerExchange Data Map
Abstract

In the PowerExchange Navigator, the term *copybook* refers generically to data definitions for records, segments, fields, keys, and other items from a data source that you import into a data map, or into records or segments in a data map, to define the layout of the data. This article shows how to import a COBOL or PL/I copybook into a data map or into records or segments in a data map.

Supported Versions

- PowerExchange 9.0.1

Table of Contents

- Copybooks Overview .............................................................  2
- Importing a COBOL or PL/I Copybook ..................................................  3
  - Importing a Copybook into a Data Map. ................................................  3
  - Importing a Copybook into a Record or a Segment. ................................  8
  - Viewing or Editing Properties for a Data Map Table. ................................  10
- Importing a COBOL Copybook into a Data Map - Example. ................................  10
  - Step 1. Add a Data Map and Import a COBOL Copybook into the Data Map ....  10
  - Step 2. Apply a Date Mask to a Field in the Data Map Record. ..................  16
  - Step 3. Use a WHERE Clause to Filter an Empty Record from the Output. .......  17
  - Step 4. Display Multiple Output Rows for Items in an OCCURS DEPENDING ON Clause. ........................................  18
- Importing a COBOL Copybook with REDEFINES Statements - Example. ..................  18
  - Step 1. Add a Data Map and Import a COBOL Copybook with REDEFINE Statements into the Data Map. ....  18
  - Step 2. Apply a Date Mask to a GROUP Field in the Data Map. ......................  21
- Importing a PL/I Copybook - Example ..................................................  23
  - Step 1. Add a Data Map and Import a PL/I Copybook into the Data Map ........  23
- Step 2. Test the Data Map. ............................................................  26
- Reference Information for Copybook Imports .............................................  26
  - Import Copybook - Source Details Dialog Box. .........................................  26
  - Import Copybook - Local Details Dialog Box. ..........................................  30
  - Import Copybook - Remote Details Dialog Box. ........................................  31
  - Import Copybook - Configuration Details Dialog Box. ..............................  33
- Record Definition and Duplicate Record Definition Dialog Boxes. .....................  34

Copybooks Overview

In the PowerExchange Navigator, the term *copybook* refers generically to data definitions for records, segments, fields, keys, and other items from a data source that you import into a data map, or into records or segments in a data map, to define the layout of the data.

Import a copybook to eliminate the need to manually define the layout of these items in a data map.

You can import a copybook when you add a data map or after you add it. You can also import one or more copybooks into a record or segment in a data map to add data definitions to the record or segment.
If a copybook contains a record or field that duplicates a record or field in a data map, you can select options to indicate how to handle the duplicate item. For example, you can choose to import, overwrite, or skip the item, or stop the import.

After you import a copybook, it is stored on the local system. You can then re-import that copybook from the local system.

The type of copybook that you can import depends on the data source type of the data map into which you are importing the copybook. You can import a COBOL or PL/I copybook into data maps for all data source types except DB2.

Use the following guidelines when you import a COBOL or PL/I copybook into the following types of data maps:

<table>
<thead>
<tr>
<th>Data Map Type</th>
<th>Guidelines</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adabas data maps</td>
<td>You must edit table properties in the data map to associate the imported field definitions with Adabas field definitions. For information, see “Viewing or Editing Properties for a Data Map Table” on page 10.</td>
</tr>
<tr>
<td>IMS DL/I batch and ODBA data maps</td>
<td>You must first import a database description block (DBD) copybook to add segment, key field, search field, and CCK field definitions from the IMS database, and to add tables to the data map. The DBD also defines the hierarchical sequence of segments. After you import a DBD, import a COBOL or PL/I copybook into each segment in the data map to overlay the segment with its COPYLIB. This action redefines the data map while maintaining the hierarchical metadata for the database.</td>
</tr>
</tbody>
</table>

This article shows how to import a COBOL or PL/I copybook into a data map or into a record or segment in a data map. Additionally, this article shows how to use sample data maps and copybooks in the examples folder in the PowerExchange installation directory to learn how to import COBOL copybooks, COBOL copybooks with REDEFINES statements, or PL/I copybooks into data maps.

For information about importing other types of copybooks into data maps, see the *PowerExchange Navigator User Guide*.

**Importing a COBOL or PL/I Copybook**

You can import a copybook when you add a data map or after you add it. You can also import one or more copybooks into a record or segment in a data map to add data definitions to the record or segment.

If a copybook contains a record or field that duplicates a record or field that is already in a data map, you can select options to indicate how to handle the duplicate item. For example, you can choose to import, overwrite, or skip the item, or stop the import.

**Importing a Copybook into a Data Map**

Import a copybook when you add a data map or after you add it.

1. Complete one of the following steps depending on whether you are importing a copybook into an existing data map or adding a data map:
   - For an existing data map, open the data map and click **File > Import Copybook**.
• If you are adding a data map, select the **Import Record Definitions** check box in the **Name** dialog box. The following figure shows this option:

![Name dialog box](image)

Then, click **Next**. Enter information in the **Access Method** dialog box, and click **Finish**.

The **Import Copybook - Source Details** dialog box appears.

2. In the **Import Copybook - Source Details** dialog box, enter information about the location and type of copybook that you want to import.

The following figure shows the dialog box:

![Import Copybook - Source Details dialog box](image)

For some copybook types, you must enter additional information.

For more information, see "Import Copybook - Source Details Dialog Box" on page 26.

**Note:** For an IMS data map, import a DBD copybook. Then, import a COBOL or PL/I copybook into each segment in the data map.

3. To display information about the last import operation, click **Last Import**.
The following figure shows the window:

![Import Copybook Information window](image)

The **Import Copybook Information** window displays the following information about the last copybook import operation:

- Whether the copybook was imported from the local or a remote system
- The name and type of the copybook
- The default actions defined for imported records, fields, and tables

To close the dialog box, click **Cancel**.

4. Click **Next**.

5. Based on whether you specified a remote or local copybook location, enter information about the copybook in one of the following dialog boxes for the data source type:

   - **Import Copybook - Remote Details** dialog box. For more information, see “Import Copybook - Remote Details Dialog Box” on page 31.
   - **Import Copybook - Local Details** dialog box. For more information, see “Import Copybook - Local Details Dialog Box” on page 30.

6. Click **Next**.

7. In the **Import Copybook - Configuration Details** dialog box, select options to define the default actions to take for imported records, fields, and tables.

   For more information, see “Import Copybook - Configuration Details Dialog Box” on page 33.

8. Click **Finish**.

9. In the **Import Copybook Information** window, review the information for the import operation.
The following figure shows the window:

![Import Copybook Information Window](image)

The **Import Copybook Information** window displays the following information:
- Whether PowerExchange imports the copybook from the local or a remote system
- The name and type of the copybook
- The default actions defined for imported records, fields, and tables

10. Click **OK**.

11. In the **Record Definition** dialog box, select an action for each imported record or segment.
   
   If the copybook contains a record or field that duplicates a record or field in the data map, the **Duplicate Record Definition** dialog box appears. In the **Duplicate Record Definition** dialog box, you can select options to indicate how to handle the duplicate item. For example, you can choose to import, overwrite, or skip the item, or stop the import.
   
   For more information, see “Record Definition and Duplicate Record Definition Dialog Boxes” on page 34.

12. Click **OK**.

13. If the copybook contains REDEFINES statements, a **Copybook Redefines** window notifies you that the copybook contains REDEFINES statements.

   The following figure shows the window:

   ![Copybook Redefines Window](image)

   Complete the following steps:
   a. To point to the line that contains the correct field, click **Redefinition > Next** or **Redefinition > Previous**.
   b. Click **Import > Resume**.

14. The **Import** window displays the imported copybook.
The following figure shows an example of this window:

![Copybook Import Example](image)

The **Copybook Message Log** window displays the results of the import operation.

The following figure shows an example of this window:

![Copybook Message Log Example](image)

**Note:** If an error message appears in the **Copybook Message Log** window, double-click the message to find the associated line in the copybook.

15. Close the **Import** window.

16. If you chose to overwrite a duplicate record or field in a data map, complete the following actions:
   - On the **Data Map** tab in the **Resource Explorer**, right-click the table that contains columns that are based on the updated record or field and click **Properties**.
   - In the **Record Dependencies** list in the **Table Properties** dialog box, select the table.
   - In the **Column Generation** list, select **Refresh with missing columns**.
   - Run a database row test on the table.

Based on the data source type for the data map and the type of copybook that you imported, you might need to complete one of the following tasks:

- If you imported a COBOL or PL/I copybook into an Adabas data map, edit the data map to associate the imported field definitions with Adabas field definitions. For information, see “Viewing or Editing Properties for a Data Map Table” on page 10.
- If you imported a DBD source into an IMS data map, import a COBOL or PL/I copybook into each segment in the data map. For more information, see “Importing a Copybook into a Record or a Segment” on page 8.
- If you imported a DDM copybook with fields defined with wide character datatypes into an Adabas for z/OS data map, PowerExchange does not select the **Wide Char** option on the **Code Page** tab in the **Field Properties** dialog box.

To set the **Wide Char** option for fields defined with the wide character datatype, complete one of the following tasks:

- Import a PREDICT or FDT copybook.
- Edit field properties in the data map.
Importing a Copybook into a Record or a Segment

Import one or more copybooks into a record or segment to add data definitions to the record or segment.

**Note:** After you import a DBD into an IMS data map, import a COBOL copybook into each segment in the data map to overlay each segment with its COPYLIB. This action redefines the data map while maintaining the hierarchical metadata information for the IMS database.

1. Open the data map.
2. On the Data Map tab in the Resource Explorer, select a record or a segment.
3. Click File > Import Copybook.
4. In the Import Copybook - Source Details dialog box, enter information about the location and type of copybook to import.

The following figure shows the dialog box:

![Import Copybook - Source Details Dialog Box](image)

For some copybook types, you must enter additional information.

For more information, see “Import Copybook - Source Details Dialog Box” on page 26.

**Note:** For an IMS data map, import a DBD copybook. Then, import a COBOL or PL/I copybook into each segment in the data map.

5. Click Next.

6. Based on whether you chose a remote or local copybook location, enter information about the copybook in one of the following dialog boxes:
   - **Import Copybook - Remote Details** dialog box. For more information, see “Import Copybook - Remote Details Dialog Box” on page 31.
   - **Import Copybook - Local Details** dialog box. For more information, see “Import Copybook - Local Details Dialog Box” on page 30.

**Note:** If security is enabled on z/OS, enter a user ID and password.

7. Click Next.

8. In the Import Copybook - Configuration Details dialog box, select the actions for imported records or segments, fields, and tables, and click Finish. For more information, see “Import Copybook - Configuration Details Dialog Box” on page 33.

9. In the Import Copybook Information window, review the information for the import operation.
The following figure shows the window:

![Import Copybook Information Window](image)

The **Import Copybook Information** window displays the following information:
- Whether PowerExchange imports the copybook from the local or a remote system
- The name and type of the copybook
- The default actions defined for imported records, fields, and tables

10. Click **OK**.

11. In the **Record Definition** dialog box, select an action for each imported record or segment.

   If the copybook contains a record or field that duplicates a record or field in the data map, the **Duplicate Record Definition** dialog box appears. In the **Duplicate Record Definition** dialog box, you can select options to indicate how to handle the duplicate item. For example, you can choose to import, overwrite, or skip the item, or stop the import.

   For more information, see “Record Definition and Duplicate Record Definition Dialog Boxes” on page 34.

12. Click **OK**.

13. If the copybook contains REDEFINES statements, a **Copybook Redefines** window notifies you that the copybook contains REDEFINES statements.

   The following figure shows the window:

   ![Copybook Redefines Window](image)

   Complete the following steps:
   a. To point to the line that contains the correct field, click **Redefinition > Next** or **Redefinition > Previous**.
   b. Click **Import > Resume**.

14. The **Import** window displays the imported copybook.

   The **Copybook Message Log** window displays the results of the import operation.

   **Note:** If an error message appears in the **Copybook Message Log** window, double-click the message to find the associated line in the copybook.

15. Close the **Import** window.
16. If you chose to overwrite a duplicate record or field in a data map, complete the following actions:

- On the Data Map tab in the Resource Explorer, right-click the table that contains columns that are based on the updated record or field and click Properties.
- In the Record Dependencies list in the Table Properties dialog box, select the table.
- In the Column Generation list, select Refresh with missing columns.
- Run a database row test on the table.

Viewing or Editing Properties for a Data Map Table

You can view or edit properties for a table in a data map.

You might change a table name or define a hierarchy in a complex table. Also, you can define how records in a complex table appear in a database row test or are mapped in a target table.

To view or edit properties for a data map table:

1. Open the data map.
2. On the Data Map tab in the Resource Explorer, right-click a table and click Properties.

   The Table Properties dialog box appears.
3. Depending on the data source for the data map, view or edit table properties on some or all tabs:
   - Definition. Properties for a complex table, including settings for how records in a complex table appear in a database row test or are mapped in a target table, and how changes in records on which the table is based are reflected in the corresponding columns in the table.
   - Keys. For Adabas, the primary key for the table.
   - IMS Options. For IMS DL/1 batch and IMS ODBA, properties for segments in a complex table.

Importing a COBOL Copybook into a Data Map - Example

In this example, you add a multiple-record data map and import a COBOL copybook into it.

This example shows how to complete the following tasks:

1. Add a data map and import a COBOL copybook that contains an OCCURS DEPENDING ON clause into the data map.
   When you add the data map, you use a fixed-length data file. After you add the data map, you create a hierarchical view of the flat file.
2. Apply a date mask to a field in a data map record.
3. Use a WHERE clause to filter an empty record from the output.
4. Display multiple output rows for items in an OCCURS DEPENDING ON clause.

This example uses the train3.dat and train3.cob files.

Step 1. Add a Data Map and Import a COBOL Copybook into the Data Map

Add a data map for a sequential flat file and import a COBOL copybook into the data map.

2. In the **Name** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schema Name</td>
<td>Enter COBOL.</td>
</tr>
<tr>
<td>Data Map Name</td>
<td>Enter map2.</td>
</tr>
<tr>
<td>Access Method</td>
<td>Select <strong>SEQ</strong>.</td>
</tr>
<tr>
<td>Import Record Definitions</td>
<td>Select this option.</td>
</tr>
</tbody>
</table>

The following figure shows the dialog box:

3. Click **Next**.

4. In the **SEQ Access Method** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
<td>Click the Browse button to browse to the train3.dat file in the examples directory.</td>
</tr>
<tr>
<td>Fixed</td>
<td>Select this option.</td>
</tr>
<tr>
<td>Size</td>
<td>Enter 60.</td>
</tr>
</tbody>
</table>
5. Click Finish.

6. In the Import Copybook - Source Details dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Select Local.</td>
</tr>
<tr>
<td>Type</td>
<td>Select COBOL.</td>
</tr>
<tr>
<td>Start</td>
<td>Enter 7.</td>
</tr>
<tr>
<td>End</td>
<td>Enter 72.</td>
</tr>
</tbody>
</table>

7. Click Next.
8. In the **Import Copybook - Local Cobol Details** dialog box, click the Browse button to browse to the train3.cob file in the examples directory.

    The following figure shows the dialog box:

![Image of the Import Copybook - Local Cobol Details dialog box]

    **Note:** To view the copybook, click **Preview**.

9. Click **Next**.

10. In the **Import Copybook - Configuration Details** dialog box, select the actions for imported records, fields, and tables and click **Finish**. For more information, see “Import Copybook - Configuration Details Dialog Box” on page 33.

11. In the **Import Copybook Information** window, review the information for the import and click **OK**.

12. In the **Record Definition** dialog box for the NAME_REC record and the ACCOUNT_REC record, click **OK**.

    The following figure shows the dialog box:

![Image of the Record Definition dialog box]

    For more information, see “Record Definition and Duplicate Record Definition Dialog Boxes” on page 34.

The **Cobol Import** window displays the imported copybook.
The following figure shows the window:

![Copybook Message Log window](image)

The **Copybook Message Log** window displays the results of the import operation.

The following figure shows the window:

![Copybook Message Log window](image)

**Note:** To find the associated line in the copybook for an error that appears in the **Copybook Message Log** window, double-click the message.

13. Close the **Cobol Import** window.
14. On the **Data Map** tab in the **Resource Explorer**, click the **NAME_REC** record.
15. In the **Record** tab, right-click the **RECTYPE** field and click **Properties**.
   The **Name** tab in the **Field Properties** dialog box appears.
16. In the **Record ID Values** box, enter 01.
The following figure shows the dialog box:

![Field Properties dialog box](image)

**Note**: To view the original properties for the field from the imported copybook, click the **Extra Properties** tab.

17. Click **OK**.

   In the **Record** window, the **RECTYPE** field icon appears in green.

18. On the **Data Map** tab in the **Resource Explorer**, click the **ACCOUNT_REC** record.

19. In the **Record** window, right-click the **RECTYPE** field and click **Properties**.

   The **Name** tab in the **Field Properties** dialog box appears.

20. In the **Record ID Values** box, enter 02.

21. Click **OK**.

   In the **Record** window, the **RECTYPE** field icon appears in green.

22. On the **Data Map** tab in the **Resource Explorer**, right-click **COBOL.map2** and click **Add Table**.

23. In the **Add Table** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Name</td>
<td>Enter both.</td>
</tr>
<tr>
<td>Available Records</td>
<td>Right-click the <strong>NAME_REC</strong> record and click <strong>Add Record</strong>. Then, right-click the <strong>ACCOUNT_REC</strong> record and click <strong>Add Record as Child</strong>.</td>
</tr>
</tbody>
</table>
The following figure shows the dialog box:

24. Click OK.
25. To view the table output before applying a date mask to the POLICY_DATE record, run a database row test. On the Data Map tab in the Resource Explorer, click the both table and click File > Database Row Test.
26. In the Database Row Test dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB Type</td>
<td>Select NRDB.</td>
</tr>
<tr>
<td>Location</td>
<td>Select local.</td>
</tr>
</tbody>
</table>

27. Click Go.

The Database Row Test Output window displays the output.
28. Close the Database Row Test Output and the Database Row Test windows.
29. Close the Database Row Test Output and Database Row Test windows.

**Step 2. Apply a Date Mask to a Field in the Data Map Record**

Apply a date mask to a field in a data map and delete extraneous fields from a table before running a database row test.

1. In the Table window for the both table, right-click the following columns one by one, and click Delete:
   - RECTYPE
   - ACCOUNT_REC_ACCOUNT
   - ACCOUNT_REC_RECTYPE

   For each record, click OK in the window that prompts you to confirm the deletion.
2. On the Data Map tab in the Resource Explorer, click the ACCOUNT_REC record.
3. In the Record window, right-click the POLICY_DATE field and click Properties.
4. In the Field Format list, select Y2-MM-D2.
5. Click **OK**.

6. On the **Data Map** tab in the **Resource Explorer**, click the both table.

7. Click **File > Database Row Test**.

8. On the **Database Row Test** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB Type</td>
<td>Select NRDB.</td>
</tr>
<tr>
<td>Location</td>
<td>Select local.</td>
</tr>
</tbody>
</table>

9. Click **Go**.

In the **Database Row Test Output** window, the POLICY_DATE column includes the century in the date format.

The following figure shows the output:

---

**Step 3. Use a WHERE Clause to Filter an Empty Record from the Output**

Use a WHERE clause to filter an empty record from the output in the **Database Row Test Output** window.

1. In the **Database Row Test** dialog box, enter the following statement in the **SQL Statement** box:
   
   ```sql
   select * from COBOL.map2.both where itemcnt > 0
   ```

2. In the **Database Row Test** dialog box, click **Go**.

   In the **Database Row Test Output** window, the fourth record, which contains no items, disappears from the output.

3. Close the **Database Row Test Output** and **Database Row Test** windows.
**Step 4. Display Multiple Output Rows for Items in an OCCURS DEPENDING ON Clause**

Display multiple output rows in the **Database Row Test Output** window for items in an OCCURS DEPENDING ON clause.

1. On the **Data Map** tab in the **Resource Explorer**, right-click the **both** table and click **Properties**.
2. In the **Table Properties** dialog box, select the **ITEMS** check box in the **Fields** list.
3. Click **OK**.
   In the Table window, the icon for the **ITEMS_L** column appears in turquoise.
4. On the **Data Map** tab in the **Resource Explorer**, click the **both** table.
5. Click **File > Database Row Test**.
6. In the **Database Row Test** dialog box, click **Go**.
   In the **Database Row Test Output** window, one row appears for each item in the record.

**Importing a COBOL Copybook with REDEFINES Statements - Example**

You can add a multiple-record data map and import a complex COBOL copybook with REDEFINES statements into it.

This example shows how to complete the following tasks:

1. Add a data map and import a COBOL copybook into it.
   When you add the data map, you use a fixed-length binary data file of EBCDIC data with 58320 records. Each record is 57 bytes long. This EBCDIC data file simulates reading data from an IBM mainframe system.
   In the **Add Data Map** dialog box, you set the skip records option to skip a header record in the data file.
   You import a COBOL copybook with line numbers in columns 1 through 6 and comments in columns 73 through 80. The COBOL copybook also contains REDEFINES statements.
   **Note:** PowerExchange ignores the comment lines in the copybook.
2. Apply a date mask to a GROUP field in the data map.

This example uses the train5.dat and train5.cob files.

**Step 1. Add a Data Map and Import a COBOL Copybook with REDEFINES Statements into the Data Map**

Add a multiple-record data map and import a COBOL copybook with REDEFINES statements into the data map.

1. On the **Resources** tab in the **Resource Explorer**, click **Add > Data Map**.
2. In the **Name** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schema Name</td>
<td>Enter COBOL.</td>
</tr>
<tr>
<td>Data Map Name</td>
<td>Enter map3.</td>
</tr>
<tr>
<td>Access Method</td>
<td>Select <strong>SEQ</strong>.</td>
</tr>
<tr>
<td>Import Record Definitions</td>
<td>Select this option.</td>
</tr>
</tbody>
</table>
The following figure shows the dialog box:

3. Click **Next**.

4. In the **SEQ Access Method** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
<td>Click the Browse button to browse to the train5.dat file in the examples directory.</td>
</tr>
<tr>
<td>Fixed</td>
<td>Select this option.</td>
</tr>
<tr>
<td>Size</td>
<td>Enter 57.</td>
</tr>
<tr>
<td>Default</td>
<td>Select this option.</td>
</tr>
<tr>
<td>Encoding</td>
<td>Select <strong>EBCDIC</strong>.</td>
</tr>
<tr>
<td>Codepage</td>
<td>Select <strong>Default</strong>.</td>
</tr>
<tr>
<td>Skip First</td>
<td>Enter 1.</td>
</tr>
</tbody>
</table>

After you set the encoding and code page, select the **Fixed** option again.
5. Click **Finish**.
6. In the **Import Copybook - Source Details** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Select <strong>Local</strong>.</td>
</tr>
<tr>
<td>Type</td>
<td>Select <strong>COBOL</strong>.</td>
</tr>
<tr>
<td>Start</td>
<td>Enter <strong>7</strong>.</td>
</tr>
<tr>
<td>End</td>
<td>Enter <strong>72</strong>.</td>
</tr>
</tbody>
</table>

7. Click **Next**.
8. In the **Import Copybook - Local Cobol Details** dialog box, click the Browse button to browse to the train5.cob file in the examples directory.

   **Note:** To view the copybook, click **Preview**.

9. Click **Next**.

10. In the **Import Copybook - Configuration Details** dialog box, select the actions for imported records, fields, and tables and click **Finish**. For more information, see "Import Copybook - Configuration Details Dialog Box" on page 33.

11. In the **Import Copybook Information** window, review the information for the import and click **OK**.

12. In the **Record Definition** dialog box for the MASTER_REC record, click **OK**.

   For more information, see "Record Definition and Duplicate Record Definition Dialog Boxes" on page 34.

   The **Copybook Redefines** window notifies you that the copybook contains REDEFINES statements.

   The **Cobol Import** window appears.

13. To point to the line that contains the PIC S9(8) field, click **Redefinition > Next** or **Redefinition > Previous**.

   The following figure shows the **Cobol Import** window with the PIC S9(8) field selected:

14. Click **Import > Resume**.

   The **Cobol Import** window displays the imported copybook.

   The **Copybook Message Log** window displays the results of the import operation.

   **Note:** The first line in the message log refers to a record in the **Cobol Import** window. Click the first line in the message log to highlight the specified record in the **Cobol Import** window.

15. Close the **Cobol Import** window.

**Step 2. Apply a Date Mask to a GROUP Field in the Data Map**

Apply a date mask to a GROUP field in a data map.

1. On the **Data Map** tab in the **Resource Explorer**, click the **MASTER_REC** record.

2. In the **Record** window, and click the **MASTER_DATE** field.

   The **Copybook Redefines** window notifies you that the copybook contains REDEFINES statements.

   For more information, see "Copybook Redefines Dialog Box" on page 34.

   The **Cobol Import** window appears.

   To point to the line that contains the PIC S9(8) field, click **Redefinition > Next** or **Redefinition > Previous**.

   The following figure shows the **Cobol Import** window with the PIC S9(8) field selected:

14. Click **Import > Resume**.

   The **Cobol Import** window displays the imported copybook.

   The **Copybook Message Log** window displays the results of the import operation.

   **Note:** The first line in the message log refers to a record in the **Cobol Import** window. Click the first line in the message log to highlight the specified record in the **Cobol Import** window.

15. Close the **Cobol Import** window.
In the next step, delete these subfields and set properties for the MASTER_DATE field to create a single date column in the database row test output from the MASTER_DATE GROUP field.

3. In the Record window, select the DATE_YY field. Press SHIFT and click DATE_DD. Click the Delete button on the toolbar.

4. On the confirmation dialog box, to view details about which cross-references will be deleted with the fields, click More Details.

5. Click Yes.

6. In the Record window, right-click the MASTER_DATE field and click Properties.

7. In the Field Properties dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field Type</td>
<td>Select CHAR.</td>
</tr>
<tr>
<td>Length</td>
<td>Enter 6.</td>
</tr>
<tr>
<td>Field Format</td>
<td>Select Y2-MM-D2. Delete the hyphens.</td>
</tr>
</tbody>
</table>

The following figure shows the dialog box:

8. Click OK.


10. Click Add > Column.

11. In the Add Column dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter new_date.</td>
</tr>
<tr>
<td>Base Field</td>
<td>Select MASTER_REC:MASTER_DATE.</td>
</tr>
</tbody>
</table>

12. Click OK.
14. Click File > Database Row Test.
15. In the Database Row Test dialog box, click Go.
   In the Database Row Test Output window, the new_date column displays the date.

**Importing a PL/I Copybook - Example**

You can substitute a PL/I copybook for a COBOL copybook. This example shows how to add a multiple-record data map and import a PL/I copybook into it.

This example shows how to complete the following tasks:

1. Add a data map and import a PL/I copybook with multiple definitions of a field into it.
   When you add the data map, you use a fixed-length binary data file of 58320 EBCDIC data records, which follow a single ASCII header record. Each record is 57 bytes long. This EBCDIC data file simulates reading data from an IBM mainframe system.
2. Test the data map.
   This example uses the train5.dat and train5.pl1 files.

**Step 1. Add a Data Map and Import a PL/I Copybook into the Data Map**

Add a data map and import a PL/I copybook into the data map.

2. In the Name dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schema Name</td>
<td>Enter PLI.</td>
</tr>
<tr>
<td>Data Map Name</td>
<td>Enter map5.</td>
</tr>
<tr>
<td>Access Method</td>
<td>Select SEQ.</td>
</tr>
<tr>
<td>Import Record Definitions</td>
<td>Select this option.</td>
</tr>
</tbody>
</table>
The following figure shows the dialog box:

3. Click **Next**.
4. In the **SEQ Access Method** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
<td>Click the Browse button to browse to the train5.dat file in the examples directory.</td>
</tr>
<tr>
<td>Fixed</td>
<td>Select this option.</td>
</tr>
<tr>
<td>Size</td>
<td>Enter 57.</td>
</tr>
<tr>
<td>Default</td>
<td>Select this option.</td>
</tr>
<tr>
<td>Encoding</td>
<td>Select <strong>EBCDIC</strong>.</td>
</tr>
<tr>
<td>Skip First</td>
<td>Enter 1.</td>
</tr>
</tbody>
</table>

After you set the encoding, select the **Fixed** option again.
5. Click **Finish**.

6. In the **Import Copybook - Source Details** dialog box, enter the following information:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Select Local.</td>
</tr>
<tr>
<td>Type</td>
<td>Select PL/1.</td>
</tr>
<tr>
<td>Start</td>
<td>Enter 1.</td>
</tr>
<tr>
<td>End</td>
<td>Enter 72.</td>
</tr>
</tbody>
</table>

7. Click **Next**.
8. In the **Import Copybook - Local PL/1 Details** dialog box, click the Browse button to browse to the train5.pl1 file in the examples directory.

   **Note:** To view the copybook, click **Preview**.

9. Click **Next**.

10. In the **Import Copybook - Configuration Details** dialog box, select the actions for imported records, fields, and tables and click **Finish**. For more information, see “Import Copybook - Configuration Details Dialog Box” on page 33.

11. In the **Import Copybook Information** window, review the information for the import and click **OK**.

12. In the **Record Definition** dialog box for the MASTER_REC record, click **OK**.

   For more information, see “Record Definition and Duplicate Record Definition Dialog Boxes” on page 34.

   The **Copybook Redefines** message box notifies you that the copybook contains two definitions of the BIN_NO field.

   The following figure shows the message box:

   ![Copybook Redefines Message Box]

   The PL/1 Import window appears.

13. To point to line 6, which contains the FIXED BINARY(16) field, click **Redefinition > Next** or **Redefinition > Previous**.

14. Click **Import > Resume**.

   The PL/1 Import window displays the imported copybook.

   The **Copybook Message Log** window displays the results of the import operation.

15. Close the **PL/1 Import** window.

**Step 2. Test the Data Map**

Run a database row test on the MASTER_REC table in the data map into which you imported the PL/I copybook.

1. On the **Data Map** tab in the **Resource Explorer**, click the **MASTER_REC** table.

2. Click **File > Database Row Test**.

3. In the message box, click **Yes** to send the PL1.map5 data map to a remote location.

   The **Data Map Remote Node** dialog box appears.

4. In the **Data Map Remote Node** dialog box, accept the default location of local and click **OK**.

   The **Database Row Test** dialog box appears.

5. In the **Database Row Test** dialog box, click **Go**.

   The **Database Row Test Output** window displays the output.

**Reference Information for Copybook Imports**

Use the following information to import copybooks into data maps or into records or segments.

**Import Copybook - Source Details Dialog Box**

Enter information about the copybook that you are importing into a data map or a record.
The following figure shows the **Import Copybook - Source Details** dialog box:

**Source**

Select the location of the copybook.

The following table describes the options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local</td>
<td>The copybook is located on the PowerExchange Navigator system.</td>
</tr>
<tr>
<td>Remote</td>
<td>The copybook is located on a remote system.</td>
</tr>
</tbody>
</table>

**Type**

Select the type of copybook. The type of copybook that you can import depends on the access method of the data map into which you are importing the copybook. For example, you can import a copybook type of ADACMP into a data map defined with the ADABAS access method only.
The following table describes the **Type** options and lists the types of data maps, by access method and corresponding data source, into which you can import each type of copybook:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Import into Data Maps Defined with Access Methods</th>
<th>Corresponding Data Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADACMP</td>
<td>File created by using the ADACMP utility.</td>
<td>ADABAS</td>
<td>Adabas file</td>
</tr>
<tr>
<td>COBOL or PL/1</td>
<td>COBOL or PL/I copybook.</td>
<td>ADABAS</td>
<td>Adabas file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DATACOM</td>
<td>CA Datacom/DB file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DB2UNLD</td>
<td>DB2 unload file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DL/1 BATCH</td>
<td>IMS database</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ESDS</td>
<td>VSAM ESDS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IMDS</td>
<td>CA IDMS/DB database</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IMS ODBA</td>
<td>IMS database accessed through a PowerExchange Listener</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ISAM</td>
<td>C-ISAM data file</td>
</tr>
<tr>
<td></td>
<td></td>
<td>KSDS</td>
<td>VSAM KSDS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MQSERIES</td>
<td>IBM MQSeries message queue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RRDS</td>
<td>VSAM RRDS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SEQ</td>
<td>Flat file or sequential data set</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TAPE</td>
<td>Tape data set</td>
</tr>
<tr>
<td></td>
<td></td>
<td>USER</td>
<td>User access method program</td>
</tr>
<tr>
<td>DATACOM</td>
<td>Datacom copybook. Provides combined CA Datacom/DB schema and COBOL copybook information.</td>
<td>DATACOM</td>
<td>CA Datacom/DB file</td>
</tr>
<tr>
<td>DB2 Catalog</td>
<td>DB2 catalog.</td>
<td>DB2</td>
<td>DB2 for i5/OS, DB2 for Linux, UNIX, and Windows, or DB2 for z/OS database</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DB2UNLD</td>
<td>DB2 unload file</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Import into Data Maps Defined with Access Methods</td>
<td>Corresponding Data Source</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DBD</td>
<td>Database description block (DBD). Adds segment, key field, search field, and CCK field definitions from the IMS database, and adds tables to the data map. Also defines the hierarchical sequence of segments.</td>
<td>DL/1 BATCH</td>
<td>IMS database</td>
</tr>
<tr>
<td>DDM</td>
<td>Natural data definition module (DDM). Provides long name and scale information.</td>
<td>ADABAS</td>
<td>Adabas file on z/OS</td>
</tr>
<tr>
<td>DDM OPEN SYS</td>
<td>Natural DDM.</td>
<td>ADABAS</td>
<td>Adabas file on Linux, UNIX, or Windows</td>
</tr>
<tr>
<td>DDS</td>
<td>Data description specifications (DDS). Describes data attributes in file descriptions that are external to the application program that processes the data.</td>
<td>SEQ</td>
<td>DB2 for i5/OS data that is accessed sequentially</td>
</tr>
<tr>
<td>FDT</td>
<td>Field definition table (FDT). Each database file has a corresponding FDT, which defines the record structure and the content of each field in the physical file. For each field in the record, the FDT defines the level, name, length, format, options, and special field and descriptor attributes. An FDT provides short names and no scale information.</td>
<td>ADABAS</td>
<td>Adabas file</td>
</tr>
<tr>
<td>IDMS</td>
<td>IDMS copybook. Provides combined CA IDMS/DB schema and COBOL copybook information.</td>
<td>IMDS</td>
<td>CA IDMS/DB database</td>
</tr>
<tr>
<td>PL/1</td>
<td>PL/I copybook.</td>
<td>See the COBOL type in this table.</td>
<td>See the COBOL type in this table.</td>
</tr>
<tr>
<td>PREDICT</td>
<td>Predict data dictionary. Provides long name and scale information.</td>
<td>ADABAS</td>
<td>Adabas file on z/OS</td>
</tr>
<tr>
<td>TEXT</td>
<td>Text file, which is a delimited format file that uses an Informatica internal format.</td>
<td>ADABAS</td>
<td>Adabas file</td>
</tr>
</tbody>
</table>
**Column Range**

Enter the start and end column range for the copybook:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>The start column number.&lt;br&gt;Valid values are from 1 through 999.&lt;br&gt;For the COBOL copybook type, default is 7.&lt;br&gt;For all other copybook types, default is 1.</td>
</tr>
<tr>
<td>End</td>
<td>The end column number.&lt;br&gt;Valid values are from 1 through 999.&lt;br&gt;For the COBOL and PL/I copybook types, default is 72.&lt;br&gt;For all other copybook types, default is 80.</td>
</tr>
</tbody>
</table>

**Note:** You cannot set a column range for DBDs imported into IMS DL/1 batch data maps.

**FDIC File Details**

For DDM or PREDICT copybook types, enter both of the following values:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database ID</td>
<td>The FDIC database ID.&lt;br&gt;Valid values are from 1 through 99999.</td>
</tr>
<tr>
<td>File Number</td>
<td>The FDIC file number.&lt;br&gt;Valid values are from 1 through 9999.&lt;br&gt;Default is 1.</td>
</tr>
</tbody>
</table>

**Natural User Library Path**

For the DDM OPEN SYS copybook type, enter the natural user library path.

Click the Browse button to browse to the path.

**Import Copybook - Local Details Dialog Box**

Enter information for the local copybook.
The following figure shows the **Import Copybook - Local Cobol Details** dialog box:

**File Name**

Enter the path and file name for the copybook, or click the Browse button to browse to the file.

Default is the last copybook imported into the data map from the local system.

**Preview**

Click **Preview** to view the copybook.

**Concatenate Field Name and Description**

For a DDS, select this option to concatenate the DDS field name and description.

Default is cleared.

---

**Import Copybook - Remote Details Dialog Box**

Enter information for the remote copybook.

The following figure shows the **Import Copybook - Remote Cobol Details** dialog box:
File Name

Enter the fully qualified file name of the copybook on the remote system.

For a DBD, enter the partitioned data set (PDS) file name and member in the following format:

$HLQ.DTLDEMO(dbname)$

Location

Location from which to import the copybook. The options are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local</td>
<td>The copybook is located on the PowerExchange Navigator system.</td>
</tr>
<tr>
<td>Remote</td>
<td>The copybook is located on a remote system.</td>
</tr>
</tbody>
</table>

The locations displayed in the Location list are defined by NODE statements in the dbmover.cfg configuration file on the PowerExchange Navigator system.

UserID

For z/OS, enter an operating system user ID, which is required if security is enabled.

Password

For z/OS, enter a password for the user ID.

Save File Locally As

Enter the path and file name on the local system where a copy of the copybook is saved, or click the Browse button to browse to a file.

Name

For a DDM, enter the DDM name.

Name Browse

For a DDM, click Name Browse to browse to the DDM.

Preview

Displays the copybook.

Not available for an IDMS copybook.

DBName

For an IDMS copybook, enter the IDMS database name.

Advanced

For an IDMS copybook, click Advanced to enter information in the IDMS Advanced Properties dialog box.
**Import Copybook - Configuration Details Dialog Box**

Select options to define the default actions to take for imported records, fields, and tables.

The following figure shows the Import Copybook - Configuration Details dialog box:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt on record import</td>
<td>Select this option to prompt for a record name when you import a record. Default is selected.</td>
</tr>
<tr>
<td>Prompt on field import</td>
<td>Select this option to prompt for a field name when you import a field. Default is cleared.</td>
</tr>
<tr>
<td>Prompt on table creation</td>
<td>Select this option to prompt for a table name when you create a table. Default is cleared.</td>
</tr>
<tr>
<td>Create table on each record imported</td>
<td>Select this option to create a table based on the record for each imported record. Default is selected.</td>
</tr>
<tr>
<td>Create tables for DL1 hierarchical paths</td>
<td>For a DBD, select this option to create all tables for all DL/1 hierarchical paths. Default is cleared.</td>
</tr>
<tr>
<td>Refresh table columns for imported records</td>
<td>For COBOL or PL/I copybooks imported into an IDMS, IMS DL/1 batch, or IMS ODBA data map, select this option to update columns in tables that are based on records that are overwritten during the copybook import operation. Default is cleared.</td>
</tr>
<tr>
<td>Select first data redefinition</td>
<td>Select this option to use the first data definition if PowerExchange finds a REDEFINES clause. Default is cleared.</td>
</tr>
<tr>
<td>Start import automatically</td>
<td>Select this option to start the import automatically. Default is selected.</td>
</tr>
<tr>
<td>Action on duplicate record</td>
<td>Specifies the action to take if PowerExchange finds a duplicate record, field, or table during the import operation. The options are:</td>
</tr>
<tr>
<td>Action on duplicate field</td>
<td>- PROMPT. Prompts for the action to take.</td>
</tr>
<tr>
<td>Action on duplicate table</td>
<td>- UNIQUE NAME. Imports the record or segment using a unique name.</td>
</tr>
<tr>
<td></td>
<td>- OVERWRITE. Overwrites the record or segment.</td>
</tr>
<tr>
<td></td>
<td>- SKIP. Skips the record or segment.</td>
</tr>
<tr>
<td></td>
<td>- APPEND. Appends the record or segment from the copybook to the record or segment in the data map. Default is PROMPT.</td>
</tr>
</tbody>
</table>
Record Definition and Duplicate Record Definition Dialog Boxes

Select an action for each imported record or segment.

The following figure shows the **Record Definition** dialog box:

![Record Definition Dialog Box](image1)

If the copybook contains a record or field that duplicates a record or field in the data map, you can select options to indicate how to handle the duplicate item. For example, you can choose to import, overwrite, or skip the item, or stop the import.

The following figure shows the **Duplicate Record Definition** dialog box:

![Duplicate Record Definition Dialog Box](image2)

The following table lists the options that you can select in the **Record Definition** and **Duplicate Record Definition** dialog boxes:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import</td>
<td>Select this option to import the item. Default is selected.</td>
</tr>
<tr>
<td>Name</td>
<td>Enter a name for the imported item. Default is the name in the copybook file.</td>
</tr>
<tr>
<td>Skip</td>
<td>Select this option to skip the import of the item. Default is cleared.</td>
</tr>
<tr>
<td>Stop Import</td>
<td>Select this option to stop the import. Default is cleared.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Generate Unique Name</td>
<td>Select this option to generate a unique name for a duplicate item. Default is cleared.</td>
</tr>
<tr>
<td>Overwrite</td>
<td>Select this option to overwrite the item for which PowerExchange found a duplicate item. If you select this option, select the type of item to overwrite, which is one of the following:</td>
</tr>
<tr>
<td></td>
<td>- Fields Only</td>
</tr>
<tr>
<td></td>
<td>- Records</td>
</tr>
<tr>
<td></td>
<td>Default is cleared.</td>
</tr>
<tr>
<td>Append</td>
<td>Select this option to append the duplicate item from the copybook to the item in the data map. Default is cleared.</td>
</tr>
<tr>
<td>Record Browse</td>
<td>Select a record in the data map to browse.</td>
</tr>
<tr>
<td>Apply to rest of import session</td>
<td>Select this option to apply the selected options to the rest of the import session. Default is cleared.</td>
</tr>
</tbody>
</table>

**Author**

Diane Fleming  
Principal Technical Writer