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ERROR: "[com.informatica.saas.infaagent.agentcore.AgentCoreStateMachine] - Unable to create metadata file due to the following [Connection timed out: connect]" while registerting/starting a Informatica Cloud Secure Agent
Problem Description
​Agentcore log:

2018-02-11 11:07:55,693 IST INFO [com.informatica.saas.infaagentv3.agentcore.AgentCorePublisher] - Starting RMI server...
2018-02-11 11:07:55,807 IST INFO [com.informatica.saas.infaagent.agentcore.impls.MainApp] - Agent Core's RMI started up.
2018-02-11 11:09:43,641 IST ERROR [com.informatica.saas.infaagent.agentcore.AgentCoreStateMachine] - Unable to create metadata file due to the following [Connection timed out: connect].
2018-02-11 11:10:57,722 IST ERROR [com.informatica.saas.infaagent.agentcore.AgentCoreStateMachine] - Unable to create metadata file due to the following [Connection timed out: connect].
Cause

The error appears when there is a connectivity issue between the secure agent server and the Informatica Cloud servers, mainly when there is a proxy but not configured or using wrong proxy details.


It could also be due to the required Informatica IPs not whitelisted at the company's firewall. Please refer to the KB article on IP whitelist below.

Solution

​Step 1: Configure the secure agent to use the right proxy details:

1.Navigate to the following directory:

<Secure Agent installation directory>/apps/agentcore

2.To update the proxy.ini file, enter the following command:

For Windows:

consoleAgentManager.bat configureProxy <proxy host> <proxy port> <proxy user name> <proxy password>

 

For Linux:

consoleAgentManager.sh configureProxy <proxy host> <proxy port> <proxy user name> <proxy password>

3.Restart the Secure Agent.​

 

Step 2:  Ensure the required IPs are whitelisted before trying to register the agent. Alternatively, whitelist Informatica's following two domains with the help of the Internal network/firewall team.

*.informatica.com

*.informaticacloud.com​

More Information
​Please refer following KB article for domain/IP whitelist. 
Applies To
Product: Cloud Data Integration
Problem Type: Connectivity
User Type: Developer
Project Phase: Configure
Product Version:
Database:
Operating System:
Other Software:

Reference
Attachments
Last Modified Date:9/15/2020 7:59 AMID:527494
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