Skip Ribbon Commands
Skip to main content
Navigate Up
Sign In

Quick Launch

Average Rating:

facebook Twitter
Email
Print Bookmark Alert me when this article is updated

Feedback

SIF call from IDQ fails to work in MDM
Problem Description
In Master Data Management (MDM), Informatica Data Quality (IDQ) web service consumer transformation is used to make Services Integration Framework (SIF) calls. All the required fields are mapped in the transformation and the call seems to fire well from IDQ. However, when checking the MDM logs, the SIF request is missing information such as the <RecordKey>, <rowID> tags.
Cause
This issue is caused because the IDQ transformation splits the input passed into multiple requests and sends partial data to MDM.
Solution
To resolve this issue, do as follows:
  1. ​The WS consumer transformation mapping has multiple groups such as Request (Top parent), get (next parent) and child tags like password, RecordKey so on. 
  2. These tags have the PKey-Fkey relation and need to be supplied with the same value to tie the record and its header to form a single request.
  3. Mappings these values made WS call to MDM successful.
More Information
Applies To
Product: Multidomain MDM
Problem Type: Configuration
User Type: Developer
Project Phase: Implement
Product Version:
Database:
Operating System:
Other Software:

Reference
Attachments
Last Modified Date:5/17/2019 5:09 AMID:571031
People who viewed this also viewed

Feedback

Did this KB document help you?



What can we do to improve this information (2000 or fewer characters)